I “bricked” my TTGO LoRa32 board

I’m working on making a simple flightcontroller for a model rocket, and I thought it would be nice to use the LoRa32 board I had laying around. It has lots of computing power (compared to atmega328p on my arduinos) and even support multithreading, which I looked forward to testing out with micropython. But as the title states, it is useless now… Well, I don’t know of its really useless, but I feel pressed on time and will have to swap back to using Arduino for now.

So here’s what happened! I decided that it would be hard to use the board on a model rocket while tethered to the pc for power, so I went ahead and found a small LiPo battery that would work perfect. The board has mini-JST connectors and I got a male mini-JST connector with it to solder onto a battery or other powersupply. So I snipped the connector off of my new battery and soldered on the right connector for the board. Then I simply connected the battery, then connected the board back into the computer and I can no longer connect to the REPL on the board. It reeeeeeeeally sucks!

I can’t even use ampy to list files or put files on the board! I chose to abort the ampy operations after several minutes.

I tried erasing the flash memory and burning the micropython image back several times, with different micropython images and tried changing flags like baud rate and flash mode to see if it made any difference. Every time it erased and burned successfully, but rshell could not seem to connect to it. The windows “mode” command showed that the board was recognized by the usb bus. It might of course be a problem with rshell since esptools works, but after some googling I’m not even a tiny bit closer to figuring out what’s wrong. So, in the name of stressing to get something airborne, I’m changing back to Arduino for now. I will try to get LoRa32 board to work in parallell to working with the fightcontroller. If I figure out what is causing these problems, I will write another blogpost about it and link it to this one for future reference! If you have any idea what is wrong, please comment!

Leave a comment

Your email address will not be published. Required fields are marked *